Scense

Full Version: Printer settings via Scense
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi All,

We have a windows 2012R2 printserver with default printsettings for the several printers. This makes it a lot easier for users to select trays, color or black and white in stead of having them go through all driver settings.

I have imported all necessary printers into Scense, added locations and scopes and they get distributed beautifully.
Only the default printing settings are not distributed. Nor do I see these settings in the property of the printer in Scense.

Is there a way to get these settings in or do I have to revert to printer distribution via GPO?

We are using Scense 10.0.

Thanks for your input.

Oscar van Klaveren
Hi Oscar,

According to this document (https://support.microsoft.com/en-us/kb/305402) the defaults should be pushed to users automatically after setting them on the server, but your question indicates that this doesn't work.

The functionality you're looking for does not come with Scense 'out-of-the-box'.
But, with some effort, it is possible to create the desired user experience, following these not so easy steps.

For this to work, you will need to install the 'Import Registry Content' extension from ScenseGuru on this forum.

Here are the steps:
  • Logon to a workstation and let Scense connect the printer
  • Configure the 'Printing Preferences' properly
  • Open regedit.exe and go to: HKEY_CURRENT_USER\Printers\Connections
  • Select the printer you've just configured
  • Right-click the printer, click 'export' and save the reg-file
  • Open the reg-file and it should look something like this:
Quote:Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Printers\Connections\,,SERVER,PRINTER]
"GuidPrinter"="{17D6B5F5-0964-47A0-A735-51E08D5B51C9}"
"Server"="\\\\SERVER"
"Provider"="win32spl.dll"
"LocalConnection"=dword:00000001
"DevMode"=hex:5c,00,5c,00,53,00,45,00,52,00,56,00,45,00,52,00,5c,00,48,00,50,\
          (and the rest of this binary value...)
  • We're only interested in the "DevMode" value, so delete the other values from the file.
  • You should now have something like this:
Quote:Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Printers\Connections\,,SERVER,PRINTER]
"DevMode"=hex:5c,00,5c,00,53,00,45,00,52,00,56,00,45,00,52,00,5c,00,48,00,50,\
         (and the rest of this binary value...)
  • Create a new 'Import Registry Content' action within the 'User logon Action' of the Printer object.
  • It's very important that this new action comes AFTER the Printer Connect action that's already there. (otherwise the printer won't connect properly)
  • Copy and Paste the reg-file content into the 'Import Registry Content' action
  • Don't forget to activate this new action
Now, every time the printer is connected, the 'defaults' are set the way you have configured them...

It's important to consider that the binary value in the registry must match the printer driver, so when the driver is changed or updated you should probably create a new reg-file.

I'm not sure if this will work with all printers, but it might be interesting to give it a try.

There might be a more elegant way of solving this, perhaps someone will post it here.
Hi Richard,

Turns out that the settings are pushed correctly to the VDI client.
This can be seen in the dirver settings and in case we print a testpage or print via notepad.
Correct settings are used, like color, papertray etc.

The actual cause is the different handling of printersettings in Office 2013, than in our previous setup.

Sorry that I posted the thread before a full investigation. On the other hand some very usefull info in your reply.

Thanks for the support.


Oscar van Klaveren